accf_http man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

ACCF_HTTP(9)		 BSD Kernel Developer's Manual		  ACCF_HTTP(9)

NAME
     accf_http — buffer incoming connections until a certain complete HTTP
     requests arrive

SYNOPSIS
     options INET
     pseudo-device accf_http

DESCRIPTION
     This is a filter to be placed on a socket that will be using accept() to
     receive incoming HTTP connections.

     Once installed on a listening socket, this filter is activated when a
     connection becomes ready to receive data (at which point accept(2) would
     usually return the connected descriptor to the application).  The filter
     prevents the descriptor from being returned immediately to the applica‐
     tion via accept(2).  The descriptor is made available to the application
     via accept(2) only when one of the following conditions is met:

     1.	  A complete, syntactically valid HTTP/1.0 or HTTP/1.1 HEAD or GET
	  request has been buffered by the kernel.

     2.	  The data buffered by the kernel cannot be part of a complete, syn‐
	  tactically valid HTTP 1.0 or HTTP/1.1 HEAD or GET request.

     The utility of accf_http is that a server will not have to context switch
     several times before performing the initial parsing of the request.  This
     effectively reduces the amount of required CPU utilization to handle
     incoming requests by keeping active processes in preforking servers such
     as Apache low and reducing the size of the file descriptor set that needs
     to be managed by interfaces such as select(), poll() or kevent() based
     servers.

EXAMPLES
     If the accf_data accept filter is present in the kernel configuration,
     this will enable the http accept filter on the socket sok.

	     struct accept_filter_arg afa;

	     bzero(&afa, sizeof(afa));
	     strcpy(afa.af_name, "httpready");
	     setsockopt(sok, SOL_SOCKET, SO_ACCEPTFILTER, &afa, sizeof(afa));

SEE ALSO
     setsockopt(2), accept_filter(9)

HISTORY
     The accept filter mechanism and the accf_http filter were introduced in
     FreeBSD 4.0.  They were ported to NetBSD by Coyote Point Systems and
     appeared in NetBSD 5.0.

AUTHORS
     This manual page and the filter were written by Alfred Perlstein.

BSD			       September 4, 2008			   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net