uiomove man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

UIO(9)			 BSD Kernel Developer's Manual			UIO(9)

NAME
     uio, uiomove — device driver I/O routines

SYNOPSIS
     #include <sys/types.h>
     #include <sys/uio.h>

     struct uio {
	     struct  iovec *uio_iov;
	     int     uio_iovcnt;
	     off_t   uio_offset;
	     size_t  uio_resid;
	     enum    uio_seg uio_segflg;
	     enum    uio_rw uio_rw;
	     struct  thread *uio_td;
     };

     int
     uiomove(caddr_t buf, int howmuch, struct uio *uiop);

DESCRIPTION
     The function uiomove() is used to handle transfer of data between buffers
     and I/O vectors that might possibly also cross the user/kernel space
     boundary.

     As a result of any read(2), write(2), readv(2), or writev(2) system call
     that is being passed to a character-device driver, the appropriate driver
     d_read or d_write entry will be called with a pointer to a struct
     dev_read_args or struct dev_write_args being passed, a member of which is
     a pointer to a struct uio.	 The transfer request is encoded in this
     structure.	 The driver itself should use uiomove() to get at the data in
     this structure.

     The fields in the uio structure are:

     uio_iov	 The array of I/O vectors to be processed.  In the case of
		 scatter/gather I/O, this will be more than one vector.

     uio_iovcnt	 The number of I/O vectors present.

     uio_offset	 The offset into the device.

     uio_resid	 The number of bytes to process.

     uio_segflg	 One of the following flags:

		 UIO_USERSPACE	The I/O vector points into a process's address
				space.

		 UIO_SYSSPACE	The I/O vector points into the kernel address
				space.

		 UIO_NOCOPY	Don't copy, already in object.

     uio_rw	 The direction of the desired transfer, either UIO_READ, or
		 UIO_WRITE.

     uio_td	 The pointer to a struct thread for the associated thread;
		 used if uio_segflg indicates that the transfer is to be made
		 from/to a process's address space.

RETURN VALUES
     uiomove() can return EFAULT from the invoked copyin(9) or copyout(9) in
     case the transfer was to/from a process's address space.

EXAMPLES
     The idea is that the driver maintains a private buffer for its data, and
     processes the request in chunks of maximal the size of this buffer.  Note
     that the buffer handling below is very simplified and won't work (the
     buffer pointer is not being advanced in case of a partial read), it's
     just here to demonstrate the uio handling.

     /* MIN() can be found there: */
     #include <sys/param.h>

     #define BUFSIZE 512
     static char buffer[BUFSIZE];

     static int data_available;	     /* amount of data that can be read */

     static int
     fooread(struct dev_read_args *ap)
     {
	     cdev_t dev = ap->a_head.a_dev;
	     int rv, amnt;

	     while (ap->a_uio->uio_resid > 0) {
		     if (data_available > 0) {
			     amnt = MIN(ap->a_uio->uio_resid, data_available);
			     if ((rv = uiomove((caddr_t)buffer, amnt, ap->a_uio))
				 != 0)
				     goto error;
			     data_available -= amnt;
		     } else {
			     tsleep(...);    /* wait for a better time */
		     }
	     }
	     return 0;
     error:
	     /* do error cleanup here */
	     return rv;
     }

SEE ALSO
     read(2), readv(2), write(2), writev(2), copyin(9), copyout(9), physio(9),
     sleep(9)

HISTORY
     The uio mechanism appeared in some early version of UNIX.

AUTHORS
     This man page was written by Jörg Wunsch.

BSD			       November 10, 2008			   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net