usb_cfg_descr man page on SmartOS

Man page or keyword search:  
man Server   16655 pages
apropos Keyword Search (all sections)
Output format
SmartOS logo
[printable version]

USB_CFG_DESCR(9S)					     USB_CFG_DESCR(9S)

NAME
       usb_cfg_descr - USB configuration descriptor

SYNOPSIS
       #include <sys/usb/usba.h>

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI)

DESCRIPTION
       The  usb_cfg_descr_t  configuration  descriptor defines attributes of a
       configuration. A configuration contains one or more interfaces. A  con‐
       figuration  descriptor acts as a header for the group of other descrip‐
       tors describing the subcomponents (for  example,	 interfaces  and  end‐
       points)	of  a configuration.  Please refer to Section 9.6.3 of the USB
       2.0  specification.  The	 USB  2.0  specification   is	available   at
       www.usb.org.

       One  or	more configuration descriptors are retrieved from a USB device
       during	device	  enumeration.	  They	  can	 be    accessed	   via
       usb_get_dev_data(9F).

       A configuration descriptor has the following fields:

	 uint8_t	 bLength		 Size of this descriptor
						 in bytes.

	 uint8_t	 bDescriptorType	 Set to USB_DESCR_TYPE_CFG.

	 uint16_t	 wTotalLength		 Total length of data returned
						 including this and all other
						 descriptors in this configuration.

	 uint8_t	 bNumInterfaces		 Number of interfaces in this
						 configuration.

	 uint8_t	 bConfigurationValue	 ID of this configuration
						 (1-based).

	 uint8_t	 iConfiguration		 Index of optional configuration
						 string. Valid if > 0.

	 uint8_t	 bmAttributes		 Configuration characteristics
						 (See below).

	 uint8_t	 bMaxPower		 Maximum power consumption, in
						 2mA units.

	 Configuration descriptors define the following bmAttributes:
	      USB_CFG_ATTR_SELFPWR	 -	Set if config not using bus power.
	      USB_CFG_ATTR_REMOTE_WAKEUP -	Set if config supports rem wakeup.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌────────────────────┬───────────────────┐
       │  ATTRIBUTE TYPE    │  ATTRIBUTE VALUE	│
       ├────────────────────┼───────────────────┤
       │Architecture	    │ PCI-based systems │
       ├────────────────────┼───────────────────┤
       │Interface stability │ Committed		│
       └────────────────────┴───────────────────┘

SEE ALSO
       attributes(5),		usb_get_alt_if(9F),	      usb_get_cfg(9F),
       usb_get_dev_data(9F),   usb_get_string_descr(9F),   usb_parse_data(9F),
       usb_ctrl_request(9S),	 usb_dev_descr(9S),	usb_dev_qlf_descr(9S),
       usb_ep_descr(9S),   usb_if_descr(9S),	usb_other_speed_cfg_descr(9S),
       usb_string_descr(9S)

				  Jan 5, 2004		     USB_CFG_DESCR(9S)
[top]

List of man pages available for SmartOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net