usb_get_string_descr man page on SmartOS

Man page or keyword search:  
man Server   16655 pages
apropos Keyword Search (all sections)
Output format
SmartOS logo
[printable version]

USB_GET_STRING_DESCR(9F)			      USB_GET_STRING_DESCR(9F)

NAME
       usb_get_string_descr - Get string descriptor from device

SYNOPSIS
       #include <sys/usb/usba.h>

       int usb_get_string_descr(dev_info_t *dip,
	    uint16_t langid, uint8_t index,
	    char *buf, size_t buflen);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI)

PARAMETERS
       dip
		 Pointer to the device's dev_info structure.

       langid
		 Language  ID.	Currently  only USB_LANG_ID (English ascii) is
		 valid.

       index
		 String index indicating descriptor to retrieve.

       buf
		 Address into which the string descriptor is placed.

       buflen
		 Size of buf in bytes.

DESCRIPTION
       The usb_get_string_descr() function retrieves a parsed string  descrip‐
       tor  from  a  device.  dip  specifies the device, while index indicates
       which descriptor to return.

       String descriptors provide  information	about  other  descriptors,  or
       information  that  is  encoded  in other descriptors, in readable form.
       Many descriptor types have one or  more	index  fields  which  identify
       string  descriptors.  (See Sections 9.5 and 9.6 of the USB 2.0 specifi‐
       cation.) For example, a configuration descriptor's  seventh  byte  con‐
       tains the string descriptor index describing a specific configuration.

       Retrieved  descriptors that do not fit into buflen bytes are truncated.
       All returned descriptors are null-terminated.

RETURN VALUES
       USB_SUCCESS
			   String descriptor is returned in buf.

       USB_INVALID_ARGS
			   dip or buf are NULL, or index or buflen is 0.

       USB_FAILURE
			   Descriptor cannot be retrieved.

CONTEXT
       May be called from user or kernel context.

EXAMPLES
	    /* Get the first string descriptor. */

	     char buf[SIZE];

	     if (usb_get_string_descr(
		 dip, USB_LANG_ID, 0, buf, SIZE) == USB_SUCCESS) {
		     cmn_err (CE_NOTE, "%s%d: %s",
			 ddi_driver_name(dip), ddi_get_instance(dip), buf);
	     }

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌────────────────────┬───────────────────┐
       │  ATTRIBUTE TYPE    │  ATTRIBUTE VALUE	│
       ├────────────────────┼───────────────────┤
       │Architecture	    │ PCI-based systems │
       ├────────────────────┼───────────────────┤
       │Interface stability │ Committed		│
       └────────────────────┴───────────────────┘

SEE ALSO
       attributes(5), usb_get_dev_data(9F), usb_string_descr(9S)

				  Jan 5, 2004	      USB_GET_STRING_DESCR(9F)
[top]

List of man pages available for SmartOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net