usb_handle_remote_wakeup man page on SmartOS

Man page or keyword search:  
man Server   16655 pages
apropos Keyword Search (all sections)
Output format
SmartOS logo
[printable version]

USB_HANDLE_REMOTE_WAKEUP(9F)			  USB_HANDLE_REMOTE_WAKEUP(9F)

NAME
       usb_handle_remote_wakeup	 -  Enable  or	disable	 remote	 wakeup on USB
       devices

SYNOPSIS
       #include <sys/usb/usba.h>

       int usb_handle_remote_wakeup(dev_info_t *dip, int cmd);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI)

PARAMETERS
       dip
	      Pointer to the device's dev_info structure.

       cmd
	      Command.	      Either	    USB_REMOTE_WAKEUP_ENABLE	    or
	      USB_REMOTE_WAKEUP_DISABLE.

DESCRIPTION
       The  usb_handle_remote_wakeup()	function  enables  or  disables remote
       wakeup on a USB device. This call can block.

RETURN VALUES
       USB_SUCCESS
		      Remote wakeup is successfully enabled or disabled.

       USB_FAILURE
		      Remote wakeup is not supported by the device. An	inter‐
		      nal error occurred.

CONTEXT
       May be called from user or kernel context.

EXAMPLES
	     uint_t *pwrstates;

	     /* Hook into device's power management.  Enable remote wakeup. */
	     if (usb_create_pm_components(dip, pwrstates) == USB_SUCCESS) {
		     usb_handle_remote_wakeup(dip, USB_REMOTE_WAKEUP_ENABLE);
	     }

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌────────────────────┬───────────────────┐
       │  ATTRIBUTE TYPE    │  ATTRIBUTE VALUE	│
       ├────────────────────┼───────────────────┤
       │Architecture	    │ PCI-based systems │
       ├────────────────────┼───────────────────┤
       │Interface stability │ Committed		│
       └────────────────────┴───────────────────┘

SEE ALSO
       attributes(5),	    pm_busy_component(9F),	pm_idle_component(9F),
       pm_lower_power(9F), pm_raise_power(9F),	usb_clr_feature(9F),  usb_cre‐
       ate_pm_components(9F),  usb_get_cfg(9F), usb_get_dev_data(9F), usb_reg‐
       ister_hotplug_cbs(9F), usb_cfg_descr(9S)

				  Feb 5, 2004	  USB_HANDLE_REMOTE_WAKEUP(9F)
[top]

List of man pages available for SmartOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net