usb_other_speed_cfg_descr man page on SmartOS

Man page or keyword search:  
man Server   16655 pages
apropos Keyword Search (all sections)
Output format
SmartOS logo
[printable version]

USB_OTHER_SPEED_CFG_DESCR(9S)			 USB_OTHER_SPEED_CFG_DESCR(9S)

NAME
       usb_other_speed_cfg_descr - USB other speed configuration descriptor

SYNOPSIS
       #include <sys/usb/usba.h>

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI)

DESCRIPTION
       The  usb_other_speed_cfg_descr_t	 configuration	descriptor defines how
       fields of a high speed device's configuration descriptor change if that
       device  is  run	at  its other speed. Fields of this descriptor reflect
       configuration descriptor field changes if a device's speed  is  changed
       from full to high speed, or from high to full speed.

       Please refer to Section 9.6.4 of the USB 2.0 specification. The USB 2.0
       specification is available at www.usb.org.

       This descriptor has the following fields:

	 uint8_t     bLength		    Size of this descriptor,
					    in bytes.

	 uint8_t     bDescriptorType	    Set to USB_DESCR_TYPE_OTHER_SPEED_CFG.

	 uint16_t    wTotalLength	    Total length of data returned */
					    including all descriptors in
					    the current other-speed
					    configuration.

	 uint8_t     bNumInterfaces	    Number of interfaces in
					    the selected configuration.

	 uint8_t     bConfigurationValue    ID of the current other-speed
					    configuration (1-based).

	 uint8_t     iConfiguration	    Configuration value.
					    Valid if > 0. Pass to
					    usb_get_string_descr(9F)
					    to retrieve string.

	 uint8_t     bmAttributes	    Configuration characteristics
					    [See usb_cfg_descr(9S).]

	 uint8_t     bMaxPower		    Maximum power consumption
					    in 2mA units.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌────────────────────┬───────────────────┐
       │  ATTRIBUTE TYPE    │  ATTRIBUTE VALUE	│
       ├────────────────────┼───────────────────┤
       │Architecture	    │ PCI-based systems │
       ├────────────────────┼───────────────────┤
       │Interface stability │ Committed		│
       └────────────────────┴───────────────────┘

SEE ALSO
       attributes(5),		usb_get_alt_if(9F),	      usb_get_cfg(9F),
       usb_get_dev_data(9F),   usb_get_string_descr(9F),   usb_parse_data(9F),
       usb_cfg_descr(9S),	usb_ctrl_request(9S),	    usb_dev_descr(9S),
       usb_dev_qlf_descr(9S)

				  Jan 5, 2004	 USB_OTHER_SPEED_CFG_DESCR(9S)
[top]

List of man pages available for SmartOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net