vsunlock man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

VSLOCK(9)		 BSD Kernel Developer's Manual		     VSLOCK(9)

NAME
     vslock, vsunlock — lock/unlock user space addresses in memory

SYNOPSIS
     #include <sys/types.h>
     #include <vm/vm.h>
     #include <vm/vm_extern.h>

     void
     vslock(caddr_t addr, u_int len);

     void
     vsunlock(caddr_t addr, u_int len);

DESCRIPTION
     The vslock() and vsunlock() functions respectively lock and unlock a
     range of addresses belonging to the currently running process into mem‐
     ory.  The actual amount of memory locked is a multiple of the machine's
     page size.	 The starting page number is computed by truncating addr to
     the nearest preceding page boundary, and by rounding up addr + len to the
     next page boundary.  The process context to use for this operation is
     taken from the global variable curproc.

BUGS
     The process pointer should be passed in as an argument.

BSD				 June 15, 1996				   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net