IEEE80211_IOCTL(9) | Kernel Developer's Manual | IEEE80211_IOCTL(9) |
int
ieee80211_cfgget(struct ieee80211com *ic, u_long cmd, void *data);
int
ieee80211_cfgset(struct ieee80211com *ic, u_long cmd, void *data);
int
ieee80211_ioctl(struct ieee80211com *ic, u_long cmd, void *data);
The ieee80211_cfgget() and ieee80211_cfgset() functions implement a legacy interface for getting and setting 802.11 interface attributes respectively. The interface is compatible with the RIDs implemented by the wi(4) driver and used by the wiconfig(8) utility.
The ieee80211_ioctl() function implements ioctls such as key management for wireless devices. Ioctls related to the Ethernet layer also pass through here, but are handed off to ether_ioctl() when no match for cmd is found.
September 12, 2006 | NetBSD 6.1 |