VFS_MOUNT man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

VFS_MOUNT(9)		 BSD Kernel Developer's Manual		  VFS_MOUNT(9)

NAME
     VFS_MOUNT — mount a filesystem

SYNOPSIS
     #include <sys/param.h>
     #include <sys/mount.h>
     #include <sys/vnode.h>

     int
     VFS_MOUNT(struct mount *mp, char *path, caddr_t data,
	 struct nameidata *ndp, struct proc *p);

DESCRIPTION
     Mount a filesystem into the system's namespace.

     Its arguments are:

     mp	   Structure representing the filesystem.

     path  Pathname where the filesystem is being mounted.

     data  Filesystem specific data.  This should be read into the kernel
	   using copyin(9).

     ndp   Contains the result of a namei(9) call on the pathname of the
	   mountpoint.

     p	   Process which is mounting the filesystem.

     This is called both to mount new filesystems and to change the attributes
     of an existing filesystem.	 If the MNT_UPDATE flag is set in mp->mnt_flag
     then the filesystem should update its internal state from the value of
     mp->mnt_flag.  This can be used, for instance, to convert a read-only
     filesystem to read-write.	It is also used by mountd(8) to update the NFS
     export information for the filesystem.

     If the MNT_UPDATE flag is not specified, then this is a newly mounted
     filesystem.  The filesystem code should allocate and initialize any pri‐
     vate data needed to represent the filesystem (it can use the mp->mnt_data
     field to store this information).

SEE ALSO
     VFS(9), vnode(9)

AUTHORS
     This man page was written by Doug Rabson.

BSD				 July 24, 1996				   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net