VFS_SYNC man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

VFS_SYNC(9)		 BSD Kernel Developer's Manual		   VFS_SYNC(9)

NAME
     VFS_SYNC — flush unwritten data

SYNOPSIS
     #include <sys/param.h>
     #include <sys/mount.h>
     #include <sys/vnode.h>

     int
     VFS_SYNC(struct mount *mp, int waitfor, struct ucred *cred,
	 struct proc *p);

DESCRIPTION
     This writes out all unwritten data in a filesystem.

     Its arguments are:

     mp	      The filesystem.

     waitfor  Whether the function should wait for I/O to complete.

     cred     The caller's credentials.

     p	      The calling process.

     This would normally call VOP_FSYNC(9) for all the vnodes in the filesys‐
     tem.

SEE ALSO
     fsync(2), sync(2), VFS(9), vnode(9), VOP_FSYNC(9)

AUTHORS
     This man page was written by Doug Rabson.

BSD				 July 24, 1996				   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net