VFS_VGET man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

VFS_VGET(9)		 BSD Kernel Developer's Manual		   VFS_VGET(9)

NAME
     VFS_VGET — convert an inode number to a vnode

SYNOPSIS
     #include <sys/param.h>
     #include <sys/mount.h>
     #include <sys/vnode.h>

     int
     VFS_VGET(struct mount *mp, ino_t ino, struct vnode **vpp);

DESCRIPTION
     This converts an inode number into a locked vnode.

     Its arguments are:

     mp	  The filesystem.

     ino  The inode representing the file.

     vpp  Return parameter for the vnode.

     This is an optional filesystem entrypoint for filesystems which have a
     unique id number for every file in the filesystem.	 It is used internally
     by the UFS filesystem and also by the NFSv3 server to implement the
     READDIRPLUS nfs call.

     If the filesystem does not support this call, then it should return
     EOPNOTSUPP.

SEE ALSO
     VFS(9), vnode(9)

AUTHORS
     This man page was written by Doug Rabson.

BSD				 July 24, 1996				   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net