VOP_ADVLOCK man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

VOP_ADVLOCK(9)		 BSD Kernel Developer's Manual		VOP_ADVLOCK(9)

NAME
     VOP_ADVLOCK — advisory record locking

SYNOPSIS
     #include <sys/param.h>
     #include <sys/vnode.h>
     #include <sys/fcntl.h>
     #include <sys/lockf.h>

     int
     VOP_ADVLOCK(struct vnode *vp, caddr_t id, int op, struct flock *fl,
	 int flags);

DESCRIPTION
     The arguments are:

     vp	    the vnode being manipulated

     id	    the id token which is changing the lock

     op	    the operation to perform (see fcntl(2))

     fl	    description of the lock

     flags  One of more of the following:

		  F_RDLCK    shared or read lock
		  F_UNLCK    unlock
		  F_WRLCK    exclusive or write lock
		  F_WAIT     Wait until lock is granted
		  F_POSIX    Use POSIX semantics for lock

     This entry point manipulates advisory record locks on the file.  Most
     filesystems delegate the work for this call to lf_advlock().

RETURN VALUES
     Zero is returned on success, otherwise an error is returned.

SEE ALSO
     fcntl(2), flock(2), vnode(9)

AUTHORS
     This man page was written by Doug Rabson.

BSD				 June 30, 1999				   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net