vput man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

VPUT(9)			 BSD Kernel Developer's Manual		       VPUT(9)

NAME
     vput — Decrement the primary reference count for a vnode and unlock it

SYNOPSIS
     #include <sys/param.h>
     #include <sys/vnode.h>

     void
     vput(struct vnode *vp);

DESCRIPTION
     Decrement the vnode's primary reference count (via the v_sysref field)
     and unlock the vnode.

     vp	 The vnode in question.

     This operation is functionally equivalent to calling vn_unlock(9) fol‐
     lowed by vrele(9).	 Releasing the last primary reference on a vnode will
     cause it to be deactivated and either moved to the free list or cached.
     Vnodes with namecache and/or VM objects are typically marked as being
     cached unless the system needs the memory for other purposes.

SEE ALSO
     vdrop(9), vget(9), vhold(9), vnode(9), vn_lock(9), vn_unlock(9), vref(9),
     vrele(9)

AUTHORS
     This manual page was written by Doug Rabson.

BSD				  May 5, 2007				   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net