vrele man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

VRELE(9)		 BSD Kernel Developer's Manual		      VRELE(9)

NAME
     vrele — Release a previously obtained primary reference for a vnode

SYNOPSIS
     #include <sys/param.h>
     #include <sys/vnode.h>

     void
     vrele(struct vnode *vp);

DESCRIPTION
     The caller is holding a primary reference to the vnode and wishes to
     release it.

     vp	 The vnode being released.

     Any code in the system which obtains a primary reference to a vnode via
     vref(9) typically releases that reference with vrele() when it is fin‐
     ished with the vnode.  Upon release of the last primary reference, the
     vnode will be deactivated and either moved to the free list for later re‐
     use or marked as being cache.  The vnode can be reactivated at any time
     prior to the system reusing it.

SEE ALSO
     vdrop(9), vget(9), vhold(9), vnode(9), vn_lock(9), vn_unlock(9), vput(9),
     vref(9)

AUTHORS
     This manual page was written by Doug Rabson.

BSD				  May 5, 2007				   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net