VFS_CHECKEXP man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

VFS_CHECKEXP(9)		 BSD Kernel Developer's Manual	       VFS_CHECKEXP(9)

NAME
     VFS_CHECKEXP — check if vnode is exported to a client

SYNOPSIS
     #include <sys/param.h>
     #include <sys/mount.h>

     int
     VFS_CHECKEXP(struct mount *mp, struct mbuf *nam, int *exflagsp,
	 struct ucred **credanonp);

DESCRIPTION
     This is used by the NFS server to check if a mount point is exported to a
     client.

     Its arguments are:

     mp		The mount point to be checked.

     nam	An mbuf containing the network address of the client.

     exflagsp	Return parameter for the export flags for this client.

     credanonp	Return parameter for the anonymous credentials for this
		client.

     This should be called on a file system's mount structure to determine if
     it is exported to a client whose address is contained in nam.

     It is generally called before VFS_FHTOVP(9) to validate that a client has
     access to the filesystem.

     The filesystem should call vfs_export_lookup() with the address of an
     appropriate netexport structure and the address of the client, nam, to
     verify that the client can access this filesystem.

RETURN VALUES
     The export flags and anonymous credentials specific to the client
     (returned by vfs_export_lookup()) will be returned in *exflagsp and
     *credanonp.

SEE ALSO
     VFS(9), VFS_FHTOVP(9), VFS_VPTOFH(9), vnode(9)

AUTHORS
     This man page was written by Alfred Perlstein.

BSD			      September 10, 1999			   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net