VFS_FHTOVP man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

VFS_FHTOVP(9)		 BSD Kernel Developer's Manual		 VFS_FHTOVP(9)

NAME
     VFS_FHTOVP — turn an NFS filehandle into a vnode

SYNOPSIS
     #include <sys/param.h>
     #include <sys/mount.h>
     #include <sys/vnode.h>

     int
     VFS_FHTOVP(struct mount *mp, struct fid *fhp, struct vnode **vpp);

DESCRIPTION
     This is used by the NFS server to turn an NFS filehandle into a vnode.

     Its arguments are:

     mp	  The filesystem.

     fhp  The filehandle to convert.

     vpp  Return parameter for the new locked vnode.

     The contents of the filehandle are defined by the filesystem and are not
     examined by any other part of the system.	It should contain enough
     information to uniquely identify a file within the filesystem as well as
     noticing when a file has been removed and the filesystem resources have
     been reused for a new file.  For instance, UFS filesystem stores the
     inode number and inode generation counter in its filehandle.

     A call to this function should generally be preceded by a call to
     VFS_CHECKEXP(9) to check if the file is accessible to the client.

RETURN VALUES
     The locked vnode for the file will be returned in *vpp.

SEE ALSO
     VFS(9), VFS_CHECKEXP(9), VFS_VPTOFH(9), vnode(9)

AUTHORS
     This man page was written by Doug Rabson.

BSD				 July 24, 1996				   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net